In The Trenches LogoThe Devolutions Blog Logo
The Front Line Against
IT Chaos & Cyber Threats

Notice Regarding High Severity Vulnerabilities in OpenSSL

Notice Regarding High Severity Vulnerabilities in OpenSSL

OpenSSL released an advisory concerning two high severity vulnerabilities in the 3.x line of releases. Devolutions products are not affected by these vulnerabilities. Remote Desktop Manager includes OpenSSL 1.1.1, as a FreeRDP dependency, which is not vulnerable.

Further details and guidance regarding these security issues can be found in the following articles:

Additionally, the National Cyber Security Centre of the Netherlands maintains a list of products that are shipping a vulnerable version of OpenSSL:

https://github.com/NCSC-NL/OpenSSL-2022/tree/main/software

Sebastien Duquette

Hi there, I'm Sebastien. In my role as Application Security Specialist, I focus on ways that we can integrate and strengthen security across all of our products. To achieve this critical objective, I work closely with our various software development teams and provide ongoing training, tools, and guidance. I believe that security must be a shared priority and commitment across the organization, and I am proud to work for a company that never loses sight of this fundamental principle.

Follow us by Email

Powered by follow.it

Devolutions is a leading provider of remote connection, password and credential management tools for sysadmins and IT pros.

DEVOLUTIONS.NET | 1000 Notre-Dame, Lavaltrie, QC J5T 1M1, Canada | infos@devolutions.net
All rights reserved © 2022 Devolutions